Power Bl IQM Reports Connector User
Documentation

Introduction

Microsoft Power Bl is a data visualization and business intelligence software available for
Windows. Power Bl can be used to import data, create data models, and build visual reports
using data from a variety of web and database connectors. The IQM Reports custom connector
for Power Bl Desktop allows users to easily access their IQM ad-serving data for running
campaigns through the Power Bl Desktop application, where it can be transformed into visual
reports for sharing and analysis. The IQM Reports connector is available to be downloaded from
GitHub: https://github.com/igmcorp/igm-powerbi-web.

Prerequisites

Before you use this connector, you must have an IQM account. You must also have the
Microsoft Power Bl application installed. Power Bl Desktop is available as a free download from
https://powerbi.microsoft.com/en-us/desktop/. If you are unfamiliar with Power Bl, detailed
documentation for the application can be found at https://docs.microsoft.com/en-us/power-bi/.

Setup

1. To use the IQM Reports Power Bl connector, first download the connector’s GitHub
repository from https://github.com/igmcorp/igm-powerbi-web. In the repository page,
select Code > Download ZIP.
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2. Open or extract the downloaded .zip file. Find the IQM Reports.mez file in the
bin\Release directory in the .zip file and place this .mez file into the
C:\Users\<User_Name>\Documents\Power Bl Desktop\Custom Connectors directory. If
this directory does not exist, create it.

3. Open Power Bl Desktop and navigate to the Options menu (File > Options and
settings > Options). In the Security tab, under Data Extensions, check the option “(Not
Recommended) Allow any extension to load without validation or warning”.
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4. Click OK and restart Power Bl Desktop. The IQM Reports connector should now be
available for use in the application.



Connect to IQM Reports Data

To retrieve data through the IQM Reports connector for use in Power Bl Desktop, follow these

instructions:

1. In the Home tab at the top, click Get Data > More. This will open the Get Data dialog,

which contains a list of data connectors.
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2. Inthe Get Data dialog, select the Online Services tab and click on the connector
labeled IQM Reports (Beta). Then, click the Connect button at the bottom of the dialog.
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3. Input the required parameters into the IQM Reports dialog and click OK. The connector
will import the ad-serving data of running campaigns for the time period starting at the
date and time specified in Date Interval Start and ending at Date Interval End. These
dates and times are interpreted as UTC, as are all date values imported from the
connector. Available Group By dimensions include Campaigns and Creatives.

IQM Reports

Date Interval Start (UTC) (@
Date Interval End (UTC) (@
Example: 3/21/2012 12:00:00 AM D

Group By (D

Second Group By (optional) (O

Sl [ |

4. Click Sign in to authorize the connector to import your IQM ad-serving data. You will be
asked for your IQM email and password, and for OAuth approval to allow Power Bl to
access your |QM data. After signing in and approving the connector for access, click
Connect.

QM Reports X

Organizational account <> [QM Reports

You aren't signed in.
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In the Navigator window, select the data tables to import from the IQM Reports
connector by checking the checkboxes next to each table you want to import. Each
Group By dimension combination provides a table of aggregated ad-serving data and a
table of daily ad-serving data; choose one or both tables. Then, click Load.
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6. Power Bl Desktop will now retrieve ad-serving reporting data according to your inputs

and convert them into tables that you can use to build reports. You can view these tables

in the Data view. The Data view allows you to view and manipulate each table in the
data set imported from the IQM Reports connector (and any other connectors you are
using), including filtering and sorting. This view also allows you to add columns and

measures to your tables, calculated from values in other columns. For more information,

see https://docs.microsoft.com/en-us/power-bi/connect-data/desktop-data-view.
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Table: Campaigns by Creatives Daily (55 rows) Column: Date (UTC) (21 distinct values)

7. To create a visual report, navigate to the Report view. Reports consist of one or more

pages, each of which can contain one or more visualizations (charts, tables, etc). To add
a visualization, click on an option in the Visualizations sidebar. Power Bl offers a variety

of built-in visualization types; see

https://docs.microsoft.com/en-us/power-bi/visuals/power-bi-visualization-types-for-report

s-and-g-and-a for a list explaining each type.

Additional visualization types can be downloaded from Microsoft AppSource, which can
be opened by clicking on More visuals > From AppSource in the Home tab.
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To add data to a visualization, click and drag the desired fields from the Fields sidebar to
the desired visualization component in the Visualizations sidebar, or directly onto the
visualization in the report preview. The Fields sidebar lists each table imported from
queries, along with their columns (fields).

In the example below, a Stacked Column Chart is selected from the Visualizations
sidebar. For this visualization type, values from the Fields sidebar can be added to the X
Axis, Y Axis, Legend, Small Multiples, or Tooltips in the Visualizations sidebar. The
following visual was created by clicking and dragging Campaign Name to X Axis,
Impressions to Y Axis, Creative Name to Legend, and Clicks to Tooltips.

Untitled - Power Bl Desktop ,O Search Sign in . — O X
File Home Insert Modeling View Help Format Data / Drill
o @ & 0[O B dEd B & &
I cony ] 8 L @ |3 72 s + V73 m
Get Excel Data SQL Enter Dataverse Recent Transform Refresh New Text Mare New  Quick Publish
v(;(FormaT painter datav workbook hubv Server data sources v datawv visual box visualsv measure measure
Clipboard Data Queries Insert Calculations Sensitivity Share A
il iimpressions and Clicks by Campaign Name and Creative Name 7 B «  Visualizations ¥»  Fields »
Creative Name ®160x500 @300x250 @ 300:50 ®320x50 © 728x30 ®igm-video @ Political lcon Test @ Test Adx o
o =]  Build visual
H - | £ Search
2 v R
ﬁg E A ~ BE, Campaigns by Creatives Daily
B ] £ o E 1A = - Compeien®
~ Campaign Name
=
Ay OO
LOOHe@W~ 05 eov
EEEER [ ¥ Creative ID
e Py E° = [0 8 @ 2}.‘- ®  Creative Name
3 & D 0 X CTR(%)
E ] ¥ Daily Budget ($)
PR [ ¥ Data Cost ($)
Campaign Name v X > [ [ pate Q)
[ ¥ ecpC($)
Y-axis =
[ ¥ eCPM ($)
Impressions N7 > [ E& end Date (UTQ)
Legend ¥ 2 Impressions
_ Creative Name X ‘:I L il @
Adx deal test Pre-bid Test Video Campaign  Don'tstop - Pretid Poltica Adx Test Campaign [ X Media Spent ($)
] Do ot De E-ECampa\gn Nam::r fest Campaign Small multiples > [ EE start Date (UTQ)
Add data fields here [] ¥ Total Budget ($)
Teslips [ ¥ Total Spent (5)
0O VCR (%)
Clicks X _ Z
[ X Video 100%
Page 1 Page 2 + Drill through [ X Video 25%
Page 1of 2 -—f——+ T0%

For detailed information on how to transform datasets into visual reports, see the Power
Bl documentation here:
https://docs.microsoft.com/en-us/power-bi/visuals/power-bi-report-visualizations.
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Publishing Reports

For users with a Power Bl Pro or Premium Per User (PPU) license, reports created in Power Bl
Desktop can be shared via the Power Bl Service at htips://app.powerbi.com/. The Power Bl
Service allows you to easily share reports and data and collaborate over Microsoft Teams for
data analysis. To share a report on the Power Bl Service, first save the report in Power Bl
Desktop (File > Save As). Then, select the Publish option in the Home tab of the Report view.
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If you are not already signed in to the Power Bl Service, Power Bl Desktop will prompt you to do
so. Follow the instructions to log in, then select the workspace you want to publish the report to.
Note that this will upload both the visual report and the underlying data set (i.e. the tables) to the
Power BI Service.
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Publish to Power BI

Select a destination
Search
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Power Bl Desktop will then upload the report to the chosen workspace. Click on Open....in
Power Bl to view the report in the Power Bl Service.

Publishing to Power BI

+ Success!

Open 'lQMReportsDocs.pbix’ in Power Bl
Get Quick Insights

'tl Did you know?

You can create a portrait view of your report, tailored for mobile phones.
On the View tab, select Mobile Layout. Learn more

Got it

From the Power Bl Service, you can share your reports and data sets, collaborate with Microsoft
Teams, build reports with uploaded data sets, and more.



Using the Report Template and Editing Queries

In the IQM Reports GitHub repository, the report_template directory contains a Power Bl report
template file, IQM_Report_Template.pbit. This file is an editable template for a visual report that
uses the IQM Reports connector, showing an example of how the connector might be used.

To use this template, extract the repository .zip file if it is not already extracted. Then, open
Power Bl Desktop and select File > Import > Power Bl template. Navigate to the directory
where the repository was extracted and select the IQM_Report_Template.pbit file to open it.

Upon opening the template, Power Bl will attempt to use the IQM Reports connector to import
data from IQM. If you are not already logged in, Power Bl will prompt you for your login
credentials. In this case, click Sign in as different user and enter your IQM account credentials

to use the report template.

Organizational account <> QM Reports

I' We couldn't authenticate with the credentials provided. Please try again.

You're already signed in.

Sign in as different user

cone

After you log in, navigate to the Report tab to view the report template. The report template
consists of several visualizations that are now pre-filled with your IQM ad-serving data according
to the predefined connector inputs present in the template file. You probably want to customize
the date range (Date Interval Start and Date Interval End) for the report data.
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To modify the connector input values and set the desired report date range, click on the Data
tab (circled) and right-click on the table whose date range you want to adjust, then select Edit

query.
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This will open the Power Query Editor window (shown below), which allows you to connect to
data sources and transform imported data sets to generate the data sources in the Model tab
and the tables in the Data tab (above). The Power Query Editor window provides many powerful
tools for transforming data, including filtering rows, calculating new columns, joining queries,
and more. For more information on the Power Query Editor, see
https://docs.microsoft.com/en-us/power-query/power-query-ui.

Next, locate the Applied Steps section in the sidebar. This section lists all the steps and
transformations applied to the data set imported from the query selected under Queries (on the
left), and allows for the editing of these transformations. Right now, only two steps are applied:
Source, which represents the connector that the query retrieves data from, as well as the
parameters passed to the connector; and Navigation, which represents the tables that are
selected to be imported from the connector in the Navigator window shown when connecting to
a connector. Under Applied Steps, click the gear icon next to Source.
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A popup window will then allow you to edit the parameters to the connector. If you are using the
report template, or have visualizations using the data set from the query, avoid changing the
Group By and Second Group By fields; this may break the visualizations that use the queries.
After you are done modifying the connector inputs, click OK. This will cause subsequent
executions of the query to use the new connector parameters. Repeat this process for each
query in the Queries sidebar whose parameters you want to modify.
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As mentioned before, the Power Query Editor provides a diverse set of tools for transforming
query data. For example, you can add new columns to the tables generated by the queries. The
following steps add a new column to a table containing daily ad-serving data that shows the
percentage of the daily budget that was spent each day:

1. Create or select a query that imports daily ad-serving data grouped by campaigns. Then,
in the Add Columns tab, select Custom Column.
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2. In the Custom Column window, enter the name of the new column and the formula to
use to calculate the value of the column. This can be a simple expression or a Power
Query M formula (see https://docs.microsoft.com/en-us/powerquery-m/). Column names
can be selected from the Available Columns list on the right. After clicking OK, this
column will be added to the table generated by the query, and a new step will be added
to the Applied Steps list.

X
Custom Column
Add a column that is computed from the other calumns.
New column name
Daily Budget Completion
Custom column formula (@ Available columns
= [#"Total Spent ($)"]/[#"Daily Budget ($)"]| | MaxBid($)
Daily Budget ($) A
Total Budget (%)
Seconds AudioVideo Viewed
Video Start
Video 25%
Video 50% Vv
Video 75%
<< Insert ‘
Learn about Power Query formulas
v/ No syntax errors have been detected. oK

3. To finalize the changes to the edited queries, click Close & Apply under the Home tab.
This will save the changes to the queries and reload the ad-serving data from the
connector.
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After making changes in the Power Query Editor, navigate back to the Report tab to view and

edit the updated report.

Power Bl has many more features for transforming data and creating reports. You can read
about the full set of features in the Microsoft documentation here:
https://docs.microsoft.com/en-us/power-bi/.
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